Duramax Diesels Forum Truck of the Week


Go Back   Duramax Diesels Forum > Duramax/Diesel Technical > Duramax Hard Parts > LLY

View Poll Results: BATTERIES DISCONNECTED DOSEN'T RESET PCM
Batteries reconnected truck cranks and starts 3 75.00%
drive 8hrs to start disconnect/reconnect the batteries 0 0%
replace the pcm or computer 1 25.00%
Multiple Choice Poll. Voters: 4. You may not vote on this poll

Reply
 
Thread Tools Display Modes
  #1  
Old 06-25-2017, 06:38 PM
gofishen2's Avatar
gofishen2 gofishen2 is offline
FNG
 
Join Date: Jun 2017
Location: N. Cali
Posts: 3
Default No crank

IN SHORT I have a 2005 GMC 2500HD DURAMAX 6.6 Turbo 100,000 miles.

The issue I'm having is a reoccurring non crank with a P0601 No Communication with the PCM using modules 18,10 what ever that means. Issue started about 8-9 months ago took about 5 mins turning the key every 30 - 60 sec"s. Was told "Starter Vapor Lock" temp 106. About once month afterwards it would occur same symptoms an issue but not a immediate issue. As daily temps lowered occurrence once every 2 months. the last 2 months to present has steadily gotten worse to the point I'm having to disconnect the batteries and it doesn’t matter if I wait 5 -10 mins or reconnect immediately it will start, I can run up to the store turn off 5 - 10 mins will still start. Any longer and I'll have to disconnect batteries. Now if I disconnect batteries for say 1/2 hr the engine service light would disappear for about 20 miles then stay on. Now it's always on. Also after disconnection and not starting right away I'll have to disconnect again in the morning or 2-3 hrs later.

IN SHORT Batteries without running key/off 12.95 key on running 14.1 or14.2. all dash lights come on when key is turn to start position as they always have also after turning the key to start upon release you can hear what seems to be a relay or something a "thumping clicking" diffidently not the starter. After disconnection it fires right up and never stalls no loss of power everything inside the cab works except for the Heated seats when the buttons are pushed the led's flicker immediately but never stay on for both seats and the Power seat adjustment options all work.


I don't know if this matters but after the 1st non crank issue occurred late last July/August while driving on a 2 lane paved back country "The Getaway" style road with bumps/dips approx 70 mph the all inside DIC's radio mirror info went dark radio still playing I thought this was very strange after tapping the dash, door controls and pushing the doom light/door control buttons with no avail and after tapping the dash a bit harder and a few more road dips and bumps at 70-75 everything came back on and has never occurred since. And I didn't experience the lengthy "no crank" issue till the 1st of this year. And now it's out of control.

I've check the grounds to the starter and most of the common grounds. could I be missing a hidden connection if so where and would the trailer connection intermediate issue have an affect on this issue. Now please correct me normally I would change the starter but after battery disconnection I'm going to say it's not a starter issue unless there's a starter ground I missed. Is there anyway to reset the PCM other than to reprogram it?
Again code P0601 is the only code that the OBD2 Innovan scanner shows as an error.
Thanks for your time and any input corrections, suggestions or recommendations to cure this before the fall Fishing/Bird season.



Thanks again have a good week



Larry
916 417 2687

feel free to call anytime when you have some spare moments.
Reply With Quote
  #2  
Old 07-04-2017, 03:19 AM
duramaxnate's Avatar
duramaxnate duramaxnate is online now
Hotrodder
 
Join Date: Feb 2014
Location: Norco, CA
Posts: 304

Default

Is there anyone in the area that you know that has a tech 2 that can try and see if it communicates with the ecm?
__________________
SOCAL DIESEL TRUCKS
WWW.SOCALDIESELTRUCKS.COM
MCFOO RACING
WWW.MCFOORACING.COM

-"Casper" 2005 GMC LBZ ECSB
Best Time: 10.59 @ 128 (Kat Driving)

-"Black Betty" 2006 GMC LBZ CCSB
Best Time: 12.70 @ 104
Mike L Trans w/ Goerend "G" T/C
Engine #2

-"Bender" 1978 Chevy C30 4x4
454/TH400 Currently
Soon...Kodiak LBZ / Ally 2000 5 speed.
and a bunch of different things to come...
"My Glamis cruiser"

-"Mobile Marriott" 2006 Fleetwood Gearbox 300fs
McFoo Racing mobile command center

-"The Xploder" 2002 Ford Explorer XLT/SE (Sucks Edition) Daily Driver. New Trans thanks to Mike L.


Thanks to all that helped me
- The McRats
- Mike L @ Inglewood Transmission
- Dan & Drew @ PPE


Reply With Quote
  #3  
Old 07-06-2017, 10:24 AM
gofishen2's Avatar
gofishen2 gofishen2 is offline
FNG
 
Join Date: Jun 2017
Location: N. Cali
Posts: 3
Default

OBD2 P0601 no communication with the PCM. And no I have no idea whom would have the scanner your requesting.
Reply With Quote
  #4  
Old 07-06-2017, 11:52 AM
JoshH's Avatar
JoshH JoshH is offline
Daggum farm truck
 
Join Date: Feb 2007
Location: Texas!!!
Posts: 12,436

Default

When you get the no start issue, rather than disconnecting the batteries, I would unplug the connectors from the ECM and verify power and ground on the appropriate pins with the key off and again with the key on.
__________________
06 Silverado 4x4 CC/SB

06 Express 2500 Duramax Van "The Dumpster"


Reply With Quote
  #5  
Old 07-07-2017, 10:01 AM
gofishen2's Avatar
gofishen2 gofishen2 is offline
FNG
 
Join Date: Jun 2017
Location: N. Cali
Posts: 3
Default Wiring schematic terms difinitions

THANKS for your quick response I am a Layman when it comes to mechanical issues other than Networking/Design. I would need to know is there a difference between a ECM and a PCM? where would they be located under the hood? There is 2 connector on the passengers side mounter to the motor very accessible says BOSCH 2 black connectors 1 bigger than the other. What I'm thinking is the PCM is right next to the battery drivers side with 3 connectors 2 12 pin 1 24 pin and they are a challenge to remove without breaking that stupid sliding quick lock it dont slide so well and the color is blue keyed connectors. is it the PCM or the BCM/ECM that has the memory and can be re-flashed? sorry don't mean to waste your time but I just want to make sure that we're on the same page same components!!
Reply With Quote
  #6  
Old 07-07-2017, 10:19 AM
IOWA LLY's Avatar
IOWA LLY IOWA LLY is offline
Yes, its really me
 
Join Date: Feb 2007
Posts: 2,002
Default

ECM is on the driver side. Sorta below the battery yes. 3 connectors.

The module on the passenger side your referring to is simply the injector driver. Or commonly called a ficm. (Fuel injector control module)


Sent from my iPhone using Tapatalk Pro
__________________
2003 GMC CCSB LLY
Built by me, tuned by me.

2009 ECI Diesel Truck Points Champion
2010 ECI Diesel Truck Points Champion
2011 ECI Diesel Truck Points Champion
2012 ECI Diesel Truck Points Champion

Big thanks to everyone who helps me.

Best 1/8th, 7.29, 98.6MPH (Street tires, fuel only, single Journal bearing GT42 charger) (2010)

Best 1/8th, 6.93, 104.24MPH (Street tires, fuel only, single HX60 turbo) (2016)

Best 1/8th, 6.60, 106.6MPH (Street tires, fuel only, single HX60 turbo) (2017)
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 12:04 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
vB.Sponsors