Duramax Diesels Forum Truck of the Week
  #1  
Old 09-17-2017, 01:10 PM
ChrisPerry's Avatar
ChrisPerry ChrisPerry is offline
...........
 
Join Date: Apr 2016
Location: Ventura, CA
Posts: 113
Default ABS, brake light, turn indicator issue

My ABS light and the brake warning light flash randomly back and forth. When my lights are on and I touch the brake the tail and running lights dim. Turn indicators turn on, but dash lights turn off.

No codes stored. At least none that my programmer or cheap scanner will pull. (Will scan with snap on scanner Monday.

So far I've checked....

Both batteries and connections
Ground under cab on frame
Ground under ds battery on frame
all bulbs in tail light assemblies
all marker light bulbs

I'll check ignition swich voltage next. If it's ok, is there anything else it could be other than the ABS control computer? How can I test the ABS computer?

Any help is appreciated.
__________________
02 GMC 2500HD, EC/LB, LB7, 2wd, 6" lift, 35" tires. ds LML manifold, PPE 260 hp tune, boost valve, race plug, Airdog 165 lift pump, CAT filter mod, mechanical egt and boost gauges, SB intake, high flow turbo horn, ported turbo exhaust housing, kbd drop in wheel, Banks Bighead wastegate, egr blocked, intake heater delete, PPE downpipe, 5 " exhaust w/ cat delete, Mike L built trans w/ Goerend R converter. Levi's heat blankets

7-6-17...New headgaskets, studs, Fed heads, and LDS replacement injectors @ 202,239 Miles
Reply With Quote
  #2  
Old 09-19-2017, 12:26 AM
ChrisPerry's Avatar
ChrisPerry ChrisPerry is offline
...........
 
Join Date: Apr 2016
Location: Ventura, CA
Posts: 113
Default

Pulled the codes with a Snap-on scanner today

P0571....... brake switch
U1000...... manufacturer controlled DTC
U1041...... loss of communication EBCM
C0281...... brake switch circuit
C0238...... wheel speed sensor mismatch

Acording to the scanner, 3 speed sensors read 3mph and 1 reads 0mph at a stop.
ABS voltage says 0.0 (again, according to the scanner)

I plan on breaking out the multimeter tomorrow and verifying voltage and grounds at the EBCM harness plugs.

Any other suggestions would be helpful.
__________________
02 GMC 2500HD, EC/LB, LB7, 2wd, 6" lift, 35" tires. ds LML manifold, PPE 260 hp tune, boost valve, race plug, Airdog 165 lift pump, CAT filter mod, mechanical egt and boost gauges, SB intake, high flow turbo horn, ported turbo exhaust housing, kbd drop in wheel, Banks Bighead wastegate, egr blocked, intake heater delete, PPE downpipe, 5 " exhaust w/ cat delete, Mike L built trans w/ Goerend R converter. Levi's heat blankets

7-6-17...New headgaskets, studs, Fed heads, and LDS replacement injectors @ 202,239 Miles
Reply With Quote
  #3  
Old 09-19-2017, 08:09 AM
duramax on fire duramax on fire is offline
Hotrodder
 
Join Date: Apr 2015
Location: dallas
Posts: 131
Default

Sounds like your losing a ground somewhere. Are you just inspecting the grounds visually or using an omh reading to verify the cable isn't broke inside.
Reply With Quote
  #4  
Old 09-19-2017, 06:45 PM
ChrisPerry's Avatar
ChrisPerry ChrisPerry is offline
...........
 
Join Date: Apr 2016
Location: Ventura, CA
Posts: 113
Default

I pulled the grounds sanded the teminals and the frame and rebolted them. For peace of mind, tonight I probed the grounds a foot from the terminals, with the positive clamped to the battery. 12.45 volts, same as dirrectly at the battery.

Came inside about 20 min ago to find a wiring diagram, when I went outside it's working perfectly.

This needs to stay broken until I figure out what's wrong. Guess I'll go for a drive and see if I can get it to act up again....
__________________
02 GMC 2500HD, EC/LB, LB7, 2wd, 6" lift, 35" tires. ds LML manifold, PPE 260 hp tune, boost valve, race plug, Airdog 165 lift pump, CAT filter mod, mechanical egt and boost gauges, SB intake, high flow turbo horn, ported turbo exhaust housing, kbd drop in wheel, Banks Bighead wastegate, egr blocked, intake heater delete, PPE downpipe, 5 " exhaust w/ cat delete, Mike L built trans w/ Goerend R converter. Levi's heat blankets

7-6-17...New headgaskets, studs, Fed heads, and LDS replacement injectors @ 202,239 Miles
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 01:12 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
vB.Sponsors