Duramax Diesels Forum Truck of the Week
  #16  
Old 07-16-2018, 01:41 PM
onebaddmaxxx onebaddmaxxx is offline
Hotrodder
 
Join Date: Feb 2009
Location: Harco, Md
Posts: 1,159
Default

Quote:
Originally Posted by CaptPhil View Post
Took five minutes, I didn't drop it all the way, just hung it on straps and moved it up against the drive shaft, I couldn't see how to get to the rear tube otherwise. Didn't even have to disconnect anything except the full line.

Remember, I don't have a fancy lift to work under, doing this shit on my back.

Sent from my SM-G900V using Tapatalk
You were more than welcome to bring it here pal

I blew the line that goes back over the tank the night i put the trans in the white devil, but roman got it through there without dropping it. Lol
__________________
2005 lly

Lots of thanks to Diesels Unlimited, Evan@limitless & Mark@danville
Reply With Quote
  #17  
Old 07-16-2018, 01:46 PM
CaptPhil's Avatar
CaptPhil CaptPhil is offline
Hotrodder
 
Join Date: Sep 2011
Location: Delaware
Posts: 998

Default

I know man, appreciate that. I got it home and all the old lines out in about an hour and a half. New lines will be here tomorrow, putting them in will probably kick my ass.

Sent from my SM-G900V using Tapatalk
__________________
2005 CC/SB LLY
Big Dipper w/ 1058
Bullseye Double bat S366

12.05 @ 112mph w/ S366, stock sticks, stock CP3

2005 EC/SB LLY The White Devil
Built Motor
Limitless Diesel Comp Trans
Triple Turbo
Dual Fuelers
100% Injectors (Hahaha Sure they are)
10.67 @ 133mph fuel only
Reply With Quote
  #18  
Old 07-16-2018, 04:46 PM
duramax on fire duramax on fire is offline
Hotrodder
 
Join Date: Apr 2015
Location: dallas
Posts: 297
Default

Never thought about rusty brake lines failing. We don't have that problem in Texas lol. Glad you didn't wreck. No brakes suck. Wife lost an idler pully last week and she almost went off a cliff without power steering and no brakes.
Reply With Quote
  #19  
Old 07-18-2018, 06:00 AM
CaptPhil's Avatar
CaptPhil CaptPhil is offline
Hotrodder
 
Join Date: Sep 2011
Location: Delaware
Posts: 998

Default

They definitely fail, lol. There were at least five or six other spots on various lines that were very close to letting go.

Got my lines here, about to jump in and get after it.

Sent from my SM-G900V using Tapatalk
__________________
2005 CC/SB LLY
Big Dipper w/ 1058
Bullseye Double bat S366

12.05 @ 112mph w/ S366, stock sticks, stock CP3

2005 EC/SB LLY The White Devil
Built Motor
Limitless Diesel Comp Trans
Triple Turbo
Dual Fuelers
100% Injectors (Hahaha Sure they are)
10.67 @ 133mph fuel only
Reply With Quote
  #20  
Old 07-18-2018, 06:43 AM
onebaddmaxxx onebaddmaxxx is offline
Hotrodder
 
Join Date: Feb 2009
Location: Harco, Md
Posts: 1,159
Default

Can’t wait to see your post about bleeding them ����
__________________
2005 lly

Lots of thanks to Diesels Unlimited, Evan@limitless & Mark@danville
Reply With Quote
  #21  
Old 07-18-2018, 10:50 AM
CaptPhil's Avatar
CaptPhil CaptPhil is offline
Hotrodder
 
Join Date: Sep 2011
Location: Delaware
Posts: 998

Default

I'm in the process now. Reman calipers on all four corners, lol. The bleeders were big balls of rust and broke off immediately. After messing with the broken parts for a little while I said to hell with it and picked up remans.

Sent from my SM-G900V using Tapatalk
__________________
2005 CC/SB LLY
Big Dipper w/ 1058
Bullseye Double bat S366

12.05 @ 112mph w/ S366, stock sticks, stock CP3

2005 EC/SB LLY The White Devil
Built Motor
Limitless Diesel Comp Trans
Triple Turbo
Dual Fuelers
100% Injectors (Hahaha Sure they are)
10.67 @ 133mph fuel only
Reply With Quote
  #22  
Old 07-18-2018, 12:53 PM
CaptPhil's Avatar
CaptPhil CaptPhil is offline
Hotrodder
 
Join Date: Sep 2011
Location: Delaware
Posts: 998

Default

Done and test drove. No leaks, abs works, pedal is firmer than it was before.

Doing the lines wasn't that bad actually. They are flexible enough to move them around without worrying about them breaking.

Bleeding wasn't bad either. I actually started up front since the mc had emptied and I had no fluid anywhere. Regular pumping with the truck off did nothing. With the truck running it moved some fluid and then pumping with the truck off worked. Moved to the rear, bled both sides, then did the front again. All gravy.

Sent from my SM-G900V using Tapatalk
__________________
2005 CC/SB LLY
Big Dipper w/ 1058
Bullseye Double bat S366

12.05 @ 112mph w/ S366, stock sticks, stock CP3

2005 EC/SB LLY The White Devil
Built Motor
Limitless Diesel Comp Trans
Triple Turbo
Dual Fuelers
100% Injectors (Hahaha Sure they are)
10.67 @ 133mph fuel only
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 08:36 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
vB.Sponsors