Duramax Diesels Forum

Duramax Diesels Forum (http://www.duramaxdiesels.com/forum/index.php)
-   Stereo & Electronics (http://www.duramaxdiesels.com/forum/forumdisplay.php?f=39)
-   -   Radio Wiring Gremlins (http://www.duramaxdiesels.com/forum/showthread.php?t=79836)

turndriverside 06-13-2018 05:05 PM

Radio Wiring Gremlins
 
Long story long, I've had my Avid 6000 nex radio in the truck for the last 4 years, it's always ran without a problem.

Last month out of the blue the sound in the speakers stopped intermittently working. All 4 speakers except for the sub would randomly cut out and only the subwoofer with it's own amp would keep playing. All it would take to fix the issue was turning the radio off and on and 4 speakers would work again just fine.

Fast forward to this week, the speakers no longer play any sound.

Here are the a few things that I've done:

1. Checked with a different deck, used the same wiring, but plugged in a newer version of the deck, still no sound, subwoofer works.
2. Checked all the fuses, engine bay and by the driver door, all are working.
3. Check the wiring all the way from the adapter wiring to the speaker, connection seems solid, multimeter confirmed that.
4. Checked with a different speaker in the truck, same wiring, still no sound coming out.
5. Took the speaker out of the truck plugged it into my offroad car, speaker works fine.

Short of getting an amp and running new wire to the speakers, I'm out of ideas.

This is my 2006 Silverado 3500, non-bose radio, no rear audio control, no onstar, came originally with the single cd radio.

I'm out of ideas, any suggestions would be appriciated

Chevy1925 06-13-2018 05:09 PM

Definitely trans and/or the fan clutch

turndriverside 06-13-2018 05:12 PM

Quote:

Originally Posted by Chevy1925 (Post 1105381)
Definitely trans and/or the fan clutch

I've removed the fan clutch and refilled the transmission with diesel fluid. Those are problems waiting to happen, let's focus on the now jimbo.

Chevy1925 06-13-2018 05:14 PM

Quote:

Originally Posted by turndriverside (Post 1105382)
I've removed the fan clutch and refilled the transmission with diesel fluid. Those are problems waiting to happen, let's focus on the now jimbo.



Why you gotta take the fun out of this? Lmao

gmduramax 06-13-2018 05:39 PM

Did you try only hooking up one speaker at a time?

Ridin'GMC 06-13-2018 06:13 PM

Do you have metro or PAC interface module? Those are most likely your issue.

turndriverside 06-13-2018 07:41 PM

Quote:

Originally Posted by gmduramax (Post 1105384)
Did you try only hooking up one speaker at a time?

I did not, I will give that a try.

Quote:

Originally Posted by Ridin'GMC (Post 1105385)
Do you have metro or PAC interface module? Those are most likely your issue.

God damn it, I was looking at this shitty plastic chinese box and was wondering myself if it's causing issues. Ordering one now. Thanks!

I'll give it a try when it comes in.

Edit - wait a second, thought you were talking about the interface to keep my steering wheels controls. That's the shitty chinese box I was refering to. Looks like the pac module has something to do with the stock subwoofer? In my case my truck didn't come with one.

Edit Edit - I have one of these, I'll order it just to be safe. https://smile.amazon.com/Axxess-ASWC...wheel+controls

Chevy1925 06-13-2018 07:44 PM

Quote:

Originally Posted by turndriverside (Post 1105401)
I did not, I will give that a try.



God damn it, I was looking at this shitty plastic chinese box and was wondering myself if it's causing issues. Ordering one now. Thanks!

I'll give it a try when it comes in.

Edit - wait a second, thought you were talking about the interface to keep my steering wheels controls. That's the shitty chinese box I was refering to. Looks like the pac module has something to do with the stock subwoofer? In my case my truck didn't come with one.



Hes talking about that module buddy. The one that keeps the door chime, steering controls and other crap workin in your rig.

Ridin'GMC 06-14-2018 02:49 AM

That module also control the speakers too.

Ridin'GMC 06-14-2018 02:59 AM

Everything goes through the can bus data. Without the interface to communicate to the BCM, the speakers won't work.

turndriverside 06-14-2018 06:32 AM

Quote:

Originally Posted by Chevy1925 (Post 1105402)
Hes talking about that module buddy. The one that keeps the door chime, steering controls and other crap workin in your rig.

No door chimes here, just that other steering wheel control.

Quote:

Originally Posted by Ridin'GMC (Post 1105429)
That module also control the speakers too.

Quote:

Originally Posted by Ridin'GMC (Post 1105430)
Everything goes through the can bus data. Without the interface to communicate to the BCM, the speakers won't work.

Got it! Thanks!

DAVe3283 06-14-2018 07:00 AM

From what I have seen of most radio's protection circuits, if there is a short on any one speaker, ALL speakers are turned off to protect the radio. The interface module could be the problem, and if it isn't, try disconnecting the speakers one at a time as close to the head unit as possible.

Or just take a multimeter and measure the resistance of all the speakers at the connector to the head unit. They should all be the same value, probably 4 or 8 ohms. If one is different from the rest, trace that wiring and see what you find.

turndriverside 06-14-2018 07:04 AM

Quote:

Originally Posted by DAVe3283 (Post 1105442)
From what I have seen of most radio's protection circuits, if there is a short on any one speaker, ALL speakers are turned off to protect the radio. The interface module could be the problem, and if it isn't, try disconnecting the speakers one at a time as close to the head unit as possible.

Or just take a multimeter and measure the resistance of all the speakers at the connector to the head unit. They should all be the same value, probably 4 or 8 ohms. If one is different from the rest, trace that wiring and see what you find.

Will do, thank you!

turndriverside 06-15-2018 03:23 PM

Checking the speaker wires with the ohm setting turned out to be the trick, all the speaker wires expect for the back rear we’re coming back with a 4.0, I took the rear right door panel off and bam.

Thanks guys!

https://s22.postimg.cc/md2l9bty9/CB0..._D38272_B2.jpg

WVRigrat05 06-15-2018 05:03 PM

Junk chevys, my LLY plugs all shit the bed one by one on my LLY, I had to put new ends on.


All times are GMT -7. The time now is 01:34 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
vB.Sponsors