LLY: injector balance [Archive] - Duramax Diesels Forum

PDA

View Full Version : LLY: injector balance


rb3500
11-17-2008, 07:12 PM
i have a question...my truck has been idling rough (kind of a lopie type idle) for awhile so i took it to the dealer to to get it checked......balance rates were out in #1-2 injectors their fix was to adjusted the computer to compensate for the injector issues and rough idle .... what did they do??? and is this really going to fix the problem

RB

WanaDmaxsub
11-17-2008, 08:06 PM
That's a new one.:confused:
Is that really what they said..really?
They may have installed an updated calibration...

rb3500
11-18-2008, 10:03 AM
yes perdy mouch what was said ...the service advisor did not seem to convinced while explaining what they did....the paper work that came back from the dealer said

FOUND #1&2 INJECTOR BALANCE RATES AND PCM OUT OF CAILBRATION

J6354 ENGINE CONTROL MODULE REPROGRAM

thanks for the help RB

JoshH
11-18-2008, 10:22 AM
Sounds like they put in a new calibration in the ECM.

slowlmm
11-18-2008, 10:44 AM
did it fix the issue ?

rb3500
11-18-2008, 12:18 PM
not realy...smoothed out the idle little but still lopie almost a surge ...seems like it is more masking the problem than fixing it....guess i will give it some more time to see if it get worse or not

MMLMM
11-18-2008, 04:48 PM
so they must have adjusted it so the rates are closer to -/+0?

I can see that smoothing it out a bit but doesnt seem like the correct way to fix it. wonder what the rates were and what they brought them back to?

rb3500
11-19-2008, 08:06 AM
i asked them for more info but they did not have or did not want to give that info ....i dont have a tool to check balance rates myself ....i will just run it a wile then take it back...

rb3500
01-19-2009, 09:11 AM
I took the truck back to the dealer .....they now found the fuel pressure regulator was bad and they replaced it ....problem seems to be solved ..... idle is smooth again

RB