Injectors [Archive] - Duramax Diesels Forum

PDA

View Full Version : Injectors


motodebaja
10-13-2012, 08:21 PM
I have replaced the #2 Injector and harness. I'm still getting a #2 injoctor code and knock/missing. Any ideas??? :confused:

motodebaja
10-13-2012, 08:25 PM
LLY: I have replaced the #2 Injector and harness. I'm still getting a #2 injector code with a knock/missing. It is intermittent, any ideas??? :confused:

TeaBagger2006
10-13-2012, 08:27 PM
you sure its #2 injector. try switching injectors aound. on lly's its been known to have issues matching injector with cylinder using efi. chech for damaged wires where the alternator is

DBUSHLB7
10-13-2012, 08:41 PM
So I may be waaay off here but it's worth a try. On LB7s anyway the male pins in the bale connectors can become unseated/poor connection with the female portion. Use a small pair of needle nose pliers to gently pull the pins towards you (which reseats them in place) I did this on my truck upon injector output circuit codes. Codes and knocking hard at idle are now gone! It's worth a try if you want me to post pics of how to do it I can.

DBUSHLB7
10-13-2012, 08:42 PM
Just posted in your other thread

motodebaja
10-13-2012, 10:12 PM
<HR style="BACKGROUND-COLOR: #d1d1e1; COLOR: #d1d1e1" SIZE=1>Thanks for the help but I'm sure its the #2 injector and the connectors are good.
<!-- / icon and title --><!-- message -->
LLY: I have replaced the #2 Injector and harness. I'm still getting a #2 injector code with a knock/missing. It is intermittent, any ideas??? :confused:

TeaBagger2006
10-14-2012, 12:10 AM
Do a compression test. Might be something else wrong. Damaged valve? Is there any fuel leaking? Did you clean the hole really good when you replaced the injector? Try switching injectors with another hole and see whathappens

hmmm intermittent you say?..... Check and double check your connections

chevyburnout1
10-15-2012, 07:51 AM
What is the specific code??

motodebaja
10-15-2012, 05:41 PM
The code is P1226. LLY: I have replaced the #2 Injector and harness. I'm still getting a #2 injector code with a knock/missing. It is intermittent. (Rechecked all the conections and the wiring harness going to the ALT ; All Good)

I have cleared the code and now CLEANED the Mass air flow sensor. The intermittent knocking has seemed to stop, but it seemed to only knock prior to being fulling warmed up. However I think it was stilling missing at one point today. No new codes, I/M monitors on the OBD2 in the "monitors viewed" still show Misfire monitor, Comprehensive Components Moritor & ERG??? :eek: Thoughts

chevyburnout1
10-15-2012, 10:48 PM
That code is not for the injector circuit to the actual injector. But the injector driver circuit from the ECM to the FICM.

Check your terminals in the main bale connectors on the driver's side valve cover. Make sure you cannot push in any of the 'male' terminals into the connector itself.

motodebaja
10-16-2012, 10:20 PM
Chevyburnout1. Thank you this was it. There was moisture in the conection. Now off to Baja!

chevyburnout1
10-17-2012, 07:49 AM
Awesome :thumb:

yammerhammer
01-09-2018, 11:23 PM
Chevyburnout1. Thank you this was it. There was moisture in the conection. Now off to Baja!im having the exact same issue. how long did this issue go intermitant? mine have does it a few time in the last 2 weeks. now it has developed a fuel knock when it is missing

Sent from my SAMSUNG-SM-G890A using Tapatalk