LLY injector questions [Archive] - Duramax Diesels Forum

PDA

View Full Version : LLY injector questions


1SIKDZL
09-11-2012, 06:24 PM
Hey all you LLY guys out there, what kind of injector issues have you had with your truck if any? My 05' has 105k miles on it and I have already replaced 2 injectors on it. 1 of them went out about a year ago when I first got the truck and sounded like a rod was knocking. I eventually found the injector and replaced it, and all was well. About three months ago another one started chattering, but I am not sure which one. Seems to do it intermittenly, and it seems to only do it when I am lugging up a hill at around 1700 rpm, or going down hill somewhat coasting around 2100 rpm under throttle and you can really hear it. I run a FASS 150 dual filter set up, and have ran tranny fluid / injector cleaner through it several times. Any thoughts? I always thought the LB7 injectors were the ones known to go out. Any feedback appreciated guys.

whitetrash21
09-11-2012, 06:27 PM
All injector can fail, the 04.5 and up years just not as often as lb7 injectors. Dirty fuel, air in the system, corrosion in the lines, bigger tunes all can lead to premature failure of them. Check your balance rates, that'll give you an idea of where to look as far as which injectors are acting up.

I got my fingers crossed, I'm at 123k miles and no failures yet. :o

paint94979
09-11-2012, 06:28 PM
throw some 2 stroke oil in there... one of my injectors was sticking closed and i ran a piss load of 2 stroke oil.

1SIKDZL
09-11-2012, 06:33 PM
Maybe I will give the 2 stroke oil a shot. It seems to idle fine and runs smooth, but I have noticed under a heavy acceleration I am puffing a little white smoke in with the black cloud of smoke. How many tanks with 2 stroke mixed in did you have to run?

PureHybrid
09-11-2012, 06:37 PM
X2 on the 2cycle oil, its meant to be burnt unlike ATF that youve been trying. I ran Stanadyne at high concentration (like 2 bottles when the tank is empty, and prefill the filter with it when it is changed) when my truck was hazing and it cleared right up! Been good for 3 years after that.

1SIKDZL
09-11-2012, 06:43 PM
All injector can fail, the 04.5 and up years just not as often as lb7 injectors. Dirty fuel, air in the system, corrosion in the lines, bigger tunes all can lead to premature failure of them. Check your balance rates, that'll give you an idea of where to look as far as which injectors are acting up.

I got my fingers crossed, I'm at 123k miles and no failures yet. :o

I just need to suck it up and spend the bucks to get EFI live. I love my PPE so far, but that is the down side, it doesn't have nearly as many diagnostic features. My PPE tuner doesn't show me my balance rates, so I may just need to take the plung and buy EFI.

1slomax
09-11-2012, 07:02 PM
i have a 190k on mine and no problems other then the harness

1SIKDZL
09-11-2012, 07:08 PM
190k?! That's pretty damn good! Do you ever run any fuel treatment or cleaner in yours?

gmac32
09-11-2012, 07:13 PM
I had 386,000 on mine before I had to replace 1 injector. 2 stroke is the best that I have tried. I run a quart per tank.

TeaBagger2006
09-11-2012, 07:13 PM
Ppe tuners do show you balance rates....

Max Attitude
09-11-2012, 07:42 PM
I had 2 replaced before the 100k warranty was up a couple years ago. I am now at almost 130k and 1 injector is getting a little high. Gonna bomb it with the power service I have, see if it helps. May try the 2 stroke too.

1SIKDZL
09-11-2012, 07:57 PM
Ppe tuners do show you balance rates....


Really? The one I have seems to only show pulse width under diagnostic options?

TeaBagger2006
09-11-2012, 08:24 PM
I had a hot+2 too and I'm 100% sure you can check them with it.

1SIKDZL
09-11-2012, 08:28 PM
Anyone else want to chime in on this? Maybe older models don't have that option, and the newer models do? I swear I have been through all of the damn options it has and the closest thing I have seen is just pulse width, no balance rates. I also see a lot of conflicting thoughts on the PPE hot+2 being able to read balance rates....so I guessing maybe older models don't have that option, I know mine is older. Anyone else have a hot + 2 that reads balance rates?

Burn Down
09-11-2012, 11:11 PM
Anyone else want to chime in on this? Maybe older models don't have that option, and the newer models do? I swear I have been through all of the damn options it has and the closest thing I have seen is just pulse width, no balance rates. I also see a lot of conflicting thoughts on the PPE hot+2 being able to read balance rates....so I guessing maybe older models don't have that option, I know mine is older. Anyone else have a hot + 2 that reads balance rates?

Why don't you just call PPE? Pretty sure they know what will do what...

Lparrill
09-12-2012, 06:33 AM
I'm at 160k and all stock injectors *fingers crossed*

hondarider552
09-12-2012, 08:18 AM
Ill read your balance rates with my efi Blake. Meet me at the track in few weeks if thats good for you.

wrcknkrw
09-12-2012, 08:27 AM
Never had injector issues, 115k so far. My fpr sticks on occasion and a healthy dose of good additive or 2 stroke always clears it.

1SIKDZL
09-12-2012, 08:37 AM
Ill read your balance rates with my efi Blake. Meet me at the track in few weeks if thats good for you.

Thanks Brian, I appreciate it man! Thanks for all the suggestions guys, I will throw some 2 stroke oil in today.

TeaBagger2006
09-12-2012, 03:53 PM
Did you call ppe? That option is in the scan option you have to scroll up or down to see more engine parameters

Andrew85
09-12-2012, 04:04 PM
I can read balance rates with my ppe standard

1SIKDZL
09-12-2012, 04:30 PM
Did you call ppe? That option is in the scan option you have to scroll up or down to see more engine parameters



I just got off the phone with Rick at PPE and confirmed that the hot+2 does not read balance rates, and that a tech 2 or efi live is needed.

Balindir
09-12-2012, 07:03 PM
255k original injectors...starting to haze a little, i never knew about running 2stroke oil definitely going to try that though.

1SIKDZL
09-12-2012, 08:18 PM
255k with original injectors? That is awesome :thumb: I wish I could have gotten that outta mine! :mad:

DIESELMAFIAPER.LB7
09-12-2012, 09:00 PM
we got 185k on ours couple are going thought it was harness issues but its not

TeaBagger2006
09-12-2012, 09:18 PM
175k on my lbz..... all rates are +/- 0.2

jealous?:D

Balindir
09-13-2012, 02:53 PM
255k with original injectors? That is awesome :thumb: I wish I could have gotten that outta mine! :mad:

The truck has been stock for all those miles so that may have something to do with it.

1SIKDZL
09-24-2012, 07:34 AM
Thanks for the 2 stroke oil suggestion guys, I have ran 2 quarts through it so far and it is pretty damn quiet now, no rattling at all! I still have a little white smoke under heavy acceleration but the rattling injector noise is gone. You guys are awesome!

demvelle
10-01-2012, 06:43 PM
i have 234,00 on stock injectors but i did have a high pressure fuel pump go out 5k miles ago..

Balindir
10-02-2012, 02:39 PM
Thanks for the 2 stroke oil suggestion guys, I have ran 2 quarts through it so far and it is pretty damn quiet now, no rattling at all! I still have a little white smoke under heavy acceleration but the rattling injector noise is gone. You guys are awesome!

So you put a 1 quart in a full tank... or both in a full tank??

duratothemax
10-02-2012, 02:46 PM
I have almost 200k on 7 original injectors. 1 of the injectors hung open at like 150k or so miles (and had to be replaced obviously), but the other 7 factory-originals are fine with good balance rates.

I put Big Dipper 40% nozzles on them at ~100k. (so yes, the nozzles have been honed/modified, but the bodies are still original)