LLY: p0642 and horrible throttle response [Archive] - Duramax Diesels Forum

PDA

View Full Version : LLY: p0642 and horrible throttle response


A_T_Ver
08-29-2010, 09:17 AM
Got a p0642 code and the throttle response is horrible, coughs and sputters when pressed, or sometimes doesn't respond and all, idles fine though. :confused:

darkness
08-29-2010, 11:33 AM
did this happen while driving or upon start up?

A_T_Ver
08-30-2010, 08:04 AM
This happened while driving. When idling its fine

lb7blksmk
08-30-2010, 10:12 AM
this has happened to mine a few times and i never found out what it was. ill be driving with no problems and then my throttle response will just die but it will idle fine.

A_T_Ver
08-30-2010, 11:05 AM
I will be putting a new TPS in just as soon as i get the right torx bit. :D

A_T_Ver
08-30-2010, 03:02 PM
Now when the truck starts coughing the oil pressure low flashes across the DIC. Then it goes back to normal. Could this be the oil pressure sensor causing all this?

darkness
08-30-2010, 03:40 PM
maybe you have a little injector harness rub going on? seems on my buddies '05 it would idle just fine but when i went to hit the gas nothing. oil pressure was low too because i remembered going out and making sure it had oil. unfortanetly i dont remember what codes it threw when it happened. that code you got is so vague because there are a few 5v things it could be???

A_T_Ver
08-31-2010, 07:23 AM
The computer i hooked it to said the p0642 would trip if the oil or fuel pressure sensors were bad or the egr, but i don't have the egr on anymore. And since it's flashing low oil pressure when it cuts out i'm changing that sensor.

A_T_Ver
08-31-2010, 02:57 PM
I started it up this afternoon and it clattered coughed and died, restarted and now i have to put it to the floor before it will move. :mad:
Anyone ever have this??

duramaxdiesel
09-01-2010, 05:06 PM
I agree. I think your wiring harness rubbed through somewhere. I've seen this a lot on LLY's.

Nick

dieselboy04'
02-09-2014, 12:55 AM
Ever figure this out? I'm having throttle issues. Already changed out the tps and it seems worse. Gonna check a few things tomorrow.